openssl从1.0.1e以下版本强制升级后缺失库文件

前几天由于openssl心脏出血漏洞,对openssl进行了升级,如果老版本是OpenSSL 1.0.1e-fips,那直接安装最新的openssl-1.0.1g-1.x86_64.rpm就行了,但是如果老版本低于1.0.1e,那直接安装1.0.1g版本就会出缺失libssl.so.10和libcrypto.so.10库文件的问题,在启动某服务或者直接yum安装等命令都会出现下面问题;且最严重问题

- 阅读全文 -

OpenSSL "heartbleed" 的安全漏洞/升级Openssl到1.0.1g版本

漏洞编码:CVE-2014-0160 ,可到 Heartbleed官网去查看详情;OpenSSL 的信息泄漏漏洞导致的安全问题,可以让互联网的任何人读取系统保护内存,这种妥协密钥用于识别服务提供者和加密流量,用户名和密码的和实际的内容。该漏洞允许攻击者窃听通讯,并通过模拟服务提供者和用户来直接从服务提供者盗取数据。   目前该问题的解决可以通过升级到 OpenSSL 1.0.1g 版本,

- 阅读全文 -

Linux用root强制踢掉已登录用户

首先使用w命令查看所有在线用户:[root@VM_152_184_centos /]# w 20:50:14 up 9 days, 5:58, 3 users, load average: 0.21, 0.05, 0.02 USER TTY FROM LOGIN@ IDLE JCPU PCPU WHAT root pts

- 阅读全文 -

CentOS系统下查看系统版本信息

1、查看CentOS内核的版本:[root@localhost ~]# cat /proc/version Linux version 2.6.18-194.el5PAE (mockbuild@builder16.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Fri Apr 2 15:37:44 EDT 20

- 阅读全文 -

Linux下查找、删除、替换命令

查看某目录下所有文件的个数:[root@localhost1 opt]# ls -l |grep "^-"|wc -l查看某目录下所有文件的个数,包括子目录里面的:[root@localhost1 opt]# ls -lR|grep "^-"|wc -l查看某目录下文件夹(目录)的个数:[root@localhost1 opt]# ls -l|grep "^d"|wc -l查看某目录下文件夹(目录

- 阅读全文 -

Citrix XenServer6.0.2安装步骤记录

Citrix Xenserver,思杰基于Linux的虚拟化服务器。Citrix XenServer是一种全面而易于管理的服务器虚拟化平台,基于强大的 Xen Hypervisor 程序之上。Xen技术被广泛看作是业界最快速、最安全的虚拟化软件。XenServer 是为了高效地管理 Windows(R) 和 Linux(R)虚拟服务器而设计的,可提供经济高效的服务器整合和业务连续性,降低成本,充分

- 阅读全文 -